Infinite loading for launch dev environment


When I click “Re-deploy”, it’s showing a loading indicator infinitely.
Is it just me?

Hey there,

Thanks for the report, our engineering team has been able to reproduce this and they are working to narrow down the root cause and getting it fixed. This currently looks like an issue with the redeploy from the UI and it seems so far that this is not blocking a redeploy from the cli.

Can you try to redeploy from the cli while we continue to get this fixed in the UI?

The Okteto Team

Hi @gabriel

I executed okteto deploy but the infinite loading was still there.
So I destroyed the environment and re-deployed. But I still see the infinite loading.

Not sure console log is helpful, but this is the error when I open “Launch Dev Environment”

Thanks for the report, that will help use identify the issue. In the meantime, as a temporary workaround, one of our engineers testing this found that when they removed the namespace and all resources and tried again that it is now is working for them. That may or may not help you but it may be something you can try to while we are getting this resolved.

The Okteto Support Team

Hi @gabriel

Glad it is helpful.

they removed the namespace and all resources and tried again that it is now is working for them.

That is exactly what I did though.
After destroy, I could deploy. But I still cannot re-deploy.

Hi @gabriel

The issue persists. Are you working on it?
Or do I have to do something to fix it?

Hey Chris,

Yes, our engineering team has a ticket for the issue and I believe it is schedule for the upcoming chart release. I will check to see if we have a forecast for the release of the fix.

The Okteto Support Team

Hi @gabriel

Oh, good. Thanks for the update. :slight_smile:

Just had a conversation with engineering. This is currently scheduled in the current sprint and our forecast for the release is the 25th of October. Depending on the pace of the release then our forecast for availability in Cloud is the 26th.

We understand that this is inconvenient but I want to double check that you have a workaround for this by removing the resources and deploying them again - is that correct?

The October Support Team

Hi @gabriel

Yes, I can destroy and deploy it again.

The issue has been resolved. Thanks for the fix.