Rasa Service is running but not listening Error

I launched my Rasa app in Okteto a few days ago and was working fine.
But when i re-ploy it with some changes, i am getting the " Service is running but not listening" Error.

This is Rasa and works on both localhost and 0.0.0.0 (Running rasa on 0.0.0.0 instead of localhost in container - #10 by souvikg10 - Rasa Open Source - Rasa Community Forum)

Can anyone please help me understand what I am missing?

which port are you using for rasa server? Сan you show the docker compose file?

Sure!! this is my docker compose:

version: ‘3.4’
services:

duckling-server:
image: rasa/duckling:latest
ports:
- 8000:8000
networks:
- all

rasa-server:
image: rasa-bot:latest
working_dir: /app
build: “./”
restart: always
volumes:
- ./actions:/app/actions
- ./data:/app/data
- ./models:/app/models
command: bash -c “rm -rf models/* && rasa train && rasa run --enable-api --cors “*” --debug”
ports:
- ‘5006:5006’
public: true
networks:
- all

rasa-actions-server:
image: rasa-bot:latest
working_dir: /app
build: “./”
restart: always
volumes:
- ./actions:/app/actions
- ./dataCsv:/app/dataCsv
- ./mnFunc:/app/mnFunc
- ./funcs:/app/funcs
command: [“rasa”, “run”, “actions”]
ports:
- ‘5055:5055’
networks:
- all

networks:
all:
driver: bridge
driver_opts:
com.docker.network.enable_ipv6: “true”

and this is my okteto.yml:
name: rasa-server
command: bash
volumes:

  • /root/.cache/pip
    sync:
  • .:/app
    forward:
  • 5006:5005
    reverse:
  • 8080:8080

try changing it this way, it helped me

okteta yml:
forward:

  • 5006:5006

in rasa-server config:

command: [“rasa”, “run”,"-m models", “–enable-api”, “–cors”,"“*”", “-p 5006”]

1 Like

Thanks a lot!!, will try this and let you know!!

Thanks a ton Meirlen!! It worked!!

Great, glad I helped you!

2 Likes