Ingress: 413 Request Entity Too Large

I’m running Okteto self-hosted cluster on DigitalOcean

Using the public endpoints I’m not able post any files to my application. Getting the error: 413 Request Entity Too Large. I first though it was a misconfiguration of my application, but every public endpoint I send it to returns the same error.

The right annotation is applied to the ingress, so not sure what is causing it.: 60M

Ingress Log:
2023/06/05 13:50:30 [error] 167#167: *8495906 client intended to send too large body: 5023721 bytes, client:, server: ~^(?<subdomain>[\w-]+)\.dev\.***\.com$, request: "POST /files/ HTTP/1.1", host: "***.com"

Right after posting I found the issue:

The okteto-wildcard ingress in the okteto namespace didn’t have the correct annotation. Adding the 200m annotation to it fixed the issue.

I believe this can be considered a bug as there also doesn’t seem a way to add the annotation to the config:

Hi @boedy,

Thank you for bringing this to our attention. I’m happy to inform you that we have identified and resolved the regression issue that occurred since version 1.8.0.

We have just released version 1.9.0, which includes a fix for this problem.

You can find more details about the fix and other improvements in the 1.9 release notes.

Additionally, we will be providing a patch for the 1.8.x release with the backported fix.

Please feel free to reach out if you have any further questions.

1 Like

The current value is set to 60M, and we are seeking better ways to enable users to customize it.