I disabled the Okteto Autoscaler and now my cluster doesn't scale down

I disabled the Okteto Autoscaler:

   enabled: false

and now my clusters doesn’t scale down anymore. How can I fix it?

1 Like

The Okteto Autoscaler could have added annotations to disable scale-down in your nodes. Check if your nodes have the annotation cluster-autoscaler.kubernetes.io/scale-down-disabled and remove it if it’s there. You can automate this with the following command:

kubectl annotate nodes --all cluster-autoscaler.kubernetes.io/scale-down-disabled-

Finally, if there is a Kubernetes Deployment whose name id or starts with autoscaler-agent in the okteto namespace, you should delete it:

kubectl delete deployment autoscaler-agent -n okteto