Can't connect okteto to eks using the vscode extension

When trying to set up okteto eks context / okteto up from vscode I get:
Command ‘Okteto: Set the context for all the Okteto commands’ resulted in an error (Context was not created, check your terminal for errors)
.okteto-vscode/okteto context use arn:aws:eks:us-east-1:xxxxxxxxx:cluster/
x Exec plugin: invalid apiVersion “

Client Version: version.Info{Major:“1”, Minor:“22”, GitVersion:“v1.22.1”, BuildDate:“2021-08-19T15:45:37Z”, GoVersion:“go1.16.7”, Compiler:“gc”, Platform:“darwin/amd64”}
Server Version: version.Info{Major:“1”, Minor:“23+”, GitVersion:“v1.23.13-eks-fb459a0”, BuildDate:“2022-10-24T20:35:40Z”, GoVersion:“go1.17.13”, Compiler:“gc”, Platform:“linux/amd64”}

This seems related to aws eks update-kubeconfig invalid apiVersion · Issue #6920 · aws/aws-cli · GitHub. We’re investigating.

If you open a terminal, and you run:

.okteto-vscode/okteto context use arn:aws:eks:us-east-1:xxxxxxxxx:cluster/

Do you get the same error?

Thanks for the reply, running in terminal gives same error:

okteto context use arn:aws:eks:us-east-1:xxxx
x Exec plugin: invalid apiVersion “

What version of the aws cli are you using? Can you try upgrading to the latest version? The team believes the issue is on that side of the auth handshake (okteto calls the aws cli to get the tokens), and that it has already been solved on the newest release.

aws --version
aws-cli/2.2.34 Python/3.8.8 Darwin/20.6.0 exe/x86_64 prompt/off