How to use an insecure docker registry

I’m trying to install and use okteto, my images are stored in a private registry on artifactory. when i try to run okteto build or okteto deploy im encountering this error:

Error checking image at registry error checking image at registry error getting image tag with digest: error getting image digest: error getting image descriptor: Get "": tcp dial failed for tls: failed to verify certificate: x509: certificate is valid for, not

Unfortunately my artifactory is not running on https but http and in order to bypass on my server it I can just set docker.artifactory.****.com as an insecure registry at /etc/docker/daemon.json

How can I make okteto to skip the verification? or can I configure my registry as an insecure one?

@roeezaidler the URL of your registry doesn’t look right, you have two dots between “artifactory” and “com”, like if a word is missing, did you redact it or it was like this in the log?

  1. Could you share what okteto chart version are you using?
  2. Could you show are did you setup the private registry?


Hi @andreafalzetti , the URL is - i tried marking with aterisks but that just bolded the text. I can do docker pulls normally if i configure the daemon.json, but I need to get okteto to also use these same settings, to allow me to connect to an insecure registry.

This is the content of my /etc/docker/daemon.json:


“default-address-pools” : [
“base” : “”,
“size” : 24
“registry-mirrors”: [“https ://”],
“insecure-registries” : [“http ://”],
“dns”: [“x.x.x.x”,“x.x.x.x”]

okteto version: 2.22.3