# How do I resolve the error \`Request Header Or Cookie Too Large\` when my service has large authentication cookies?

**URL:** <https://community.okteto.com/t/how-do-i-resolve-the-error-request-header-or-cookie-too-large-when-my-service-has-large-authentication-cookies/1429>\
**Category:** How Do I?\
**Created:** [September 26, 2025, 2:43pm UTC](https://community.okteto.com/t/how-do-i-resolve-the-error-request-header-or-cookie-too-large-when-my-service-has-large-authentication-cookies/1429 "2025-09-26T14:43:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jona](https://sea1.discourse-cdn.com/flex019/user_avatar/community.okteto.com/jona/32/353_2.png) [@jona](https://community.okteto.com/u/jona)\
**Post date:** [September 26, 2025, 2:43pm UTC](https://community.okteto.com/t/how-do-i-resolve-the-error-request-header-or-cookie-too-large-when-my-service-has-large-authentication-cookies/1429/1 "2025-09-26T14:43:46Z")

</div>

How do I resolve the error `Request Header Or Cookie Too Large` ? I am running into this issue because my service requires very large authentication cookies.

---

<div class="post-metadata">

**Author:** ![jona](https://sea1.discourse-cdn.com/flex019/user_avatar/community.okteto.com/jona/32/353_2.png) [@jona](https://community.okteto.com/u/jona)\
**Post date:** [September 26, 2025, 6:06pm UTC](https://community.okteto.com/t/how-do-i-resolve-the-error-request-header-or-cookie-too-large-when-my-service-has-large-authentication-cookies/1429/2 "2025-09-26T18:06:26Z")

</div>

This error happens when HTTP headers (often big cookies) exceed NGINX’s default buffer sizes. The fix is to update **all layers** that handle requests:

1. **Internet-facing Okteto Ingress Controller**. This is the first point of entry for requests from outside the cluster. In the Okteto Helm Chart configuration, set:

2. **Internal Okteto Ingress Controller** : This is the second layer of ingress controllers for requests that go to Development Environments ingresses. In the Okteto Helm Chart configuration, set:

3. **Your Service’s NGINX** : If your application itself is running NGINX, you’ll also need to set this directive in its config file:
