# Help

**URL:** https://community.okteto.com/c/help/6.md

[Latest](https://community.okteto.com/latest.md) · [Categories](https://community.okteto.com/categories.md) · [Tags](https://community.okteto.com/tags.md)

---

## [About the Help category](https://community.okteto.com/t/about-the-help-category/26)

<div class="topic-metadata">

**Author:** [@arsh](https://community.okteto.com/u/arsh)\
**Replies:** 0\
**Last updated:** [April 25, 2022, 5:17am UTC](https://community.okteto.com/t/about-the-help-category/26 "2022-04-25T05:17:54Z")

</div>

This category is for asking for help from the Okteto community on any problems you might be facing. Help us help you better by keeping in mind the following guidelines when posting: More details are always good! The …

---

## [Post Mortem - Okteto User Activity Metrics Incident](https://community.okteto.com/t/post-mortem-okteto-user-activity-metrics-incident/1452)

<div class="topic-metadata">

**Author:** [@ramiro](https://community.okteto.com/u/ramiro)\
**Replies:** 0\
**Last updated:** [February 5, 2026, 6:02pm UTC](https://community.okteto.com/t/post-mortem-okteto-user-activity-metrics-incident/1452 "2026-02-05T18:02:02Z")

</div>

Okteto User Activity Metrics Incident Customer Postmortem & Adoption Recovery Plan Date: February 2026 Prepared by: Okteto Leadership Team 1. Executive Summary The Active User metrics displayed in Okteto Insights for c…

---

## [Troubleshooting Git SSH Clone Issues with Submodules on Different Hosts](https://community.okteto.com/t/troubleshooting-git-ssh-clone-issues-with-submodules-on-different-hosts/1272)

<div class="topic-metadata">

**Author:** [@provecho](https://community.okteto.com/u/provecho)\
**Replies:** 2\
**Last updated:** [October 13, 2025, 4:37pm UTC](https://community.okteto.com/t/troubleshooting-git-ssh-clone-issues-with-submodules-on-different-hosts/1272 "2025-10-13T16:37:32Z")

</div>

When cloning a Git repository that contains submodules from another server using SSH, I encounter an error: Host key verification failed. fatal: Could not read from remote repository. Please make sure you have the corre…

---

## [Buildkit service not available after installing Okteto](https://community.okteto.com/t/buildkit-service-not-available-after-installing-okteto/1425)

<div class="topic-metadata">

**Author:** [@Polyhistor](https://community.okteto.com/u/Polyhistor)\
**Replies:** 9\
**Last updated:** [September 29, 2025, 9:02pm UTC](https://community.okteto.com/t/buildkit-service-not-available-after-installing-okteto/1425 "2025-09-29T21:02:15Z")

</div>

So I did follow all the instructions step by step in my already deployed EKS, I did add the CSI driver, the AWS controller and all of that. But then every other thing I tried was actually problematic. I did try to insta…

---

## [Why do developers get "authentication handshake failed: missing selected ALPN property" error with okteto deploy or build?](https://community.okteto.com/t/why-do-developers-get-authentication-handshake-failed-missing-selected-alpn-property-error-with-okteto-deploy-or-build/1419)

<div class="topic-metadata">

**Author:** [@ramiro](https://community.okteto.com/u/ramiro)\
**Replies:** 1\
**Last updated:** [August 5, 2025, 6:26pm UTC](https://community.okteto.com/t/why-do-developers-get-authentication-handshake-failed-missing-selected-alpn-property-error-with-okteto-deploy-or-build/1419 "2025-08-05T18:26:40Z")

</div>

When I run okteto deploy or okteto build, the command fails with this error: authentication handshake failed: missing selected ALPN property

---

## [Persistent Volume Data Loss After Re-deploying Dev Environment](https://community.okteto.com/t/persistent-volume-data-loss-after-re-deploying-dev-environment/1389)

<div class="topic-metadata">

**Author:** [@sienna](https://community.okteto.com/u/sienna)\
**Replies:** 1\
**Last updated:** [May 2, 2025, 8:57pm UTC](https://community.okteto.com/t/persistent-volume-data-loss-after-re-deploying-dev-environment/1389 "2025-05-02T20:57:25Z")

</div>

Hello I am running into a confusing issue where persistent volume data in my Okteto dev environment seems to vanish after re-deploying the stack / restarting the environment. :innocent:I was under the impression that d…

---

## [Failed to restore session due to unexpected error](https://community.okteto.com/t/failed-to-restore-session-due-to-unexpected-error/1395)

<div class="topic-metadata">

**Author:** [@srinikr1972](https://community.okteto.com/u/srinikr1972)\
**Replies:** 10\
**Last updated:** [April 16, 2025, 2:13pm UTC](https://community.okteto.com/t/failed-to-restore-session-due-to-unexpected-error/1395 "2025-04-16T14:13:11Z")

</div>

I am deploying self hosted okteto 1.31.0 onto my kubernetes. when i try to login to portal, i get error message “Failed to restore session due to unexpected error. Please try again or report issue if problem persists.”

---

## [Preventing Okteto / syncthing from writing logs to stdout](https://community.okteto.com/t/preventing-okteto-syncthing-from-writing-logs-to-stdout/1372)

<div class="topic-metadata">

**Author:** [@HarelSultan](https://community.okteto.com/u/HarelSultan)\
**Replies:** 2\
**Last updated:** [January 22, 2025, 6:42am UTC](https://community.okteto.com/t/preventing-okteto-syncthing-from-writing-logs-to-stdout/1372 "2025-01-22T06:42:11Z")

</div>

Hi, I’m using the OSS version of Okteto to setup a development container on my kubernetes cluster. Everything works fine so far, and I’ve recently started working on the logging setup for my development pod. My applica…

---

## [What is the difference between the "okteto deploy" and "okteto pipeline deploy"?](https://community.okteto.com/t/what-is-the-difference-between-the-okteto-deploy-and-okteto-pipeline-deploy/1365)

<div class="topic-metadata">

**Author:** [@ramiro](https://community.okteto.com/u/ramiro)\
**Replies:** 1\
**Last updated:** [January 13, 2025, 10:18pm UTC](https://community.okteto.com/t/what-is-the-difference-between-the-okteto-deploy-and-okteto-pipeline-deploy/1365 "2025-01-13T22:18:22Z")

</div>

When is okteto deploy recommended, and when should I use okteto pipeline deploy?

---

## [Can I use the Okteto CLI on my Kubernetes cluster?](https://community.okteto.com/t/can-i-use-the-okteto-cli-on-my-kubernetes-cluster/1364)

<div class="topic-metadata">

**Author:** [@midprasanta](https://community.okteto.com/u/midprasanta)\
**Replies:** 1\
**Last updated:** [January 9, 2025, 1:04am UTC](https://community.okteto.com/t/can-i-use-the-okteto-cli-on-my-kubernetes-cluster/1364 "2025-01-09T01:04:36Z")

</div>

Hi @ramiro , I was using okteto CLI to run dev/debug on my local kube cluster. Recently I upgraded CLI version 3.X.X. and since then okteto commands stop wroking. Now its is asking for cloud url. Is latest CLI not wo…

---

## [Why my post hidden at community](https://community.okteto.com/t/why-my-post-hidden-at-community/1353)

<div class="topic-metadata">

**Author:** [@SKThakur](https://community.okteto.com/u/SKThakur)\
**Replies:** 2\
**Last updated:** [December 18, 2024, 12:03am UTC](https://community.okteto.com/t/why-my-post-hidden-at-community/1353 "2024-12-18T00:03:28Z")

</div>

Hello Team, after a few days, I got a notification that left me disappointed as it shows my content is Hidden. I don’t know what is the reason behind it but I didn’t do anything wrong that violates community guidelines. …

---

## ["no space left on device" when building images](https://community.okteto.com/t/no-space-left-on-device-when-building-images/1345)

<div class="topic-metadata">

**Author:** [@pchico83](https://community.okteto.com/u/pchico83)\
**Replies:** 1\
**Last updated:** [November 27, 2024, 12:41pm UTC](https://community.okteto.com/t/no-space-left-on-device-when-building-images/1345 "2024-11-27T12:41:49Z")

</div>

When building my images, I am getting “no space left on device” errors

---

## [AWS Registered Targets shown as Unhealthy](https://community.okteto.com/t/aws-registered-targets-shown-as-unhealthy/1340)

<div class="topic-metadata">

**Author:** [@jona](https://community.okteto.com/u/jona)\
**Replies:** 1\
**Last updated:** [November 7, 2024, 6:33pm UTC](https://community.okteto.com/t/aws-registered-targets-shown-as-unhealthy/1340 "2024-11-07T18:33:15Z")

</div>

In my AWS cluster with Okteto installed I see that most of my Node Registered Targets are shown as unhealthy except for a few. However, when I check my Nodes with the command kubectl get nodes, and ping them, they all …

---

## [I want help for a Multi Service Deployment in Okteto with Persistent Volume](https://community.okteto.com/t/i-want-help-for-a-multi-service-deployment-in-okteto-with-persistent-volume/1336)

<div class="topic-metadata">

**Author:** [@joshuaevans](https://community.okteto.com/u/joshuaevans)\
**Replies:** 1\
**Last updated:** [October 16, 2024, 4:08pm UTC](https://community.okteto.com/t/i-want-help-for-a-multi-service-deployment-in-okteto-with-persistent-volume/1336 "2024-10-16T16:08:20Z")

</div>

Hi everyone, I a working on deploying a multi service application using Okteto & I have hit a bit of a snag with persistent volumes. My application has multiple containers, one of which requires data persistence between…

---

## [SSH Server creates RSA key but Visual Studio 17.10 does not support it](https://community.okteto.com/t/ssh-server-creates-rsa-key-but-visual-studio-17-10-does-not-support-it/1298)

<div class="topic-metadata">

**Author:** [@logic01](https://community.okteto.com/u/logic01)\
**Replies:** 2\
**Last updated:** [September 5, 2024, 4:37pm UTC](https://community.okteto.com/t/ssh-server-creates-rsa-key-but-visual-studio-17-10-does-not-support-it/1298 "2024-09-05T16:37:05Z")

</div>

When you run okteto up an SSH key is created using RSA. However, Visual Studio 2022 17.10 only supports EC keys when attaching to a remote process.

---

## [Why my post has been Hidden?](https://community.okteto.com/t/why-my-post-has-been-hidden/1325)

<div class="topic-metadata">

**Author:** [@roberrttt](https://community.okteto.com/u/roberrttt)\
**Replies:** 1\
**Last updated:** [September 5, 2024, 12:19pm UTC](https://community.okteto.com/t/why-my-post-has-been-hidden/1325 "2024-09-05T12:19:55Z")

</div>

Hello there, Recently I posted a query on this website- https://community.okteto.com/t/akismet-has-temporarily-hidden-your-post/1323 After few minutes, I got a notification that left me disappointed as it shows my c…

---

## [Could Someone Give me Advice for Optimizing Development Workflow with Okteto?](https://community.okteto.com/t/could-someone-give-me-advice-for-optimizing-development-workflow-with-okteto/1322)

<div class="topic-metadata">

**Author:** [@roberrttt](https://community.okteto.com/u/roberrttt)\
**Replies:** 0\
**Last updated:** [August 29, 2024, 4:25am UTC](https://community.okteto.com/t/could-someone-give-me-advice-for-optimizing-development-workflow-with-okteto/1322 "2024-08-29T04:25:08Z")

</div>

Hello there, I have been using Okteto for a few months now, and while I have seen some great productivity boosts, I feel like I am only scratching the surface of what the platform can do. I am working on a fairly comple…

---

## [Okteto VSCode extension can't connect to remote container](https://community.okteto.com/t/okteto-vscode-extension-cant-connect-to-remote-container/1311)

<div class="topic-metadata">

**Author:** [@ramiro](https://community.okteto.com/u/ramiro)\
**Replies:** 1\
**Last updated:** [August 1, 2024, 6:50pm UTC](https://community.okteto.com/t/okteto-vscode-extension-cant-connect-to-remote-container/1311 "2024-08-01T18:50:15Z")

</div>

When I run the “Okteto: up” command on the VS Code Extension, VSCode fails to connect to the remote container with the following error:

---

## [Using internal URL for okteto/bin:1.5.0](https://community.okteto.com/t/using-internal-url-for-okteto-bin-1-5-0/1304)

<div class="topic-metadata">

**Author:** [@russkey007](https://community.okteto.com/u/russkey007)\
**Replies:** 2\
**Last updated:** [July 25, 2024, 3:03pm UTC](https://community.okteto.com/t/using-internal-url-for-okteto-bin-1-5-0/1304 "2024-07-25T15:03:21Z")

</div>

Hi, Trying Okteto for the first time, following the documentation. When running command “okteto up” I see that the pod is created in the target cluster namespace, but it is failing to pull this image: docker.io/okteto/…

---

## [Running postgress with okteto cli not working](https://community.okteto.com/t/running-postgress-with-okteto-cli-not-working/1300)

<div class="topic-metadata">

**Author:** [@jplasencia](https://community.okteto.com/u/jplasencia)\
**Replies:** 2\
**Last updated:** [July 23, 2024, 12:36am UTC](https://community.okteto.com/t/running-postgress-with-okteto-cli-not-working/1300 "2024-07-23T00:36:10Z")

</div>

Hello: Is there a reason I am not able to run a database with the okteto cli? Below is my okteto manifest file for a postgres database. Whenever I run this, I get an error with the command. I have tried different notati…

---

## [Important Update: Migrating to New Implementation of Okteto Pod Tolerations and Node Selectors](https://community.okteto.com/t/important-update-migrating-to-new-implementation-of-okteto-pod-tolerations-and-node-selectors/1281)

<div class="topic-metadata">

**Author:** [@jona](https://community.okteto.com/u/jona)\
**Replies:** 0\
**Last updated:** [May 24, 2024, 12:47pm UTC](https://community.okteto.com/t/important-update-migrating-to-new-implementation-of-okteto-pod-tolerations-and-node-selectors/1281 "2024-05-24T12:47:20Z")

</div>

Hi community, We’re excited to announce an upcoming update to the Okteto chart that improves how you configure and manage pod tolerations and node selectors. In Okteto chart 2.0, we are removing the current tolerations …

---

## [Question on okteto and syncthing relaying](https://community.okteto.com/t/question-on-okteto-and-syncthing-relaying/1270)

<div class="topic-metadata">

**Author:** [@jplasencia](https://community.okteto.com/u/jplasencia)\
**Replies:** 15\
**Last updated:** [May 22, 2024, 6:21pm UTC](https://community.okteto.com/t/question-on-okteto-and-syncthing-relaying/1270 "2024-05-22T18:21:06Z")

</div>

Our security team has raised concerns about the potential use of relaying during file synchronization with Okteto. Despite Syncthing relaying being disabled by default in Okteto, as verified through the command: okteto …

---

## [Unable to connect to Kubernetes cluster](https://community.okteto.com/t/unable-to-connect-to-kubernetes-cluster/411)

<div class="topic-metadata">

**Author:** [@manninga](https://community.okteto.com/u/manninga)\
**Replies:** 3\
**Last updated:** [May 22, 2024, 2:53pm UTC](https://community.okteto.com/t/unable-to-connect-to-kubernetes-cluster/411 "2024-05-22T14:53:53Z")

</div>

While attempting to use the Okteto CLI to deploy a “hello world” app on my own Kubernetes cluster, I encounter an error like this: $ okteto deploy i Using default @ my-cluster as context i Images were already built.…

---

## [Secret / env variable not getting substituted for dev environments](https://community.okteto.com/t/secret-env-variable-not-getting-substituted-for-dev-environments/416)

<div class="topic-metadata">

**Author:** [@benjoldersma](https://community.okteto.com/u/benjoldersma)\
**Replies:** 8\
**Last updated:** [May 15, 2024, 2:11pm UTC](https://community.okteto.com/t/secret-env-variable-not-getting-substituted-for-dev-environments/416 "2024-05-15T14:11:10Z")

</div>

I have a DATABASE\_URL that I’m configuring for my preview environments, and using a github action to run integration tests against. That works great, as a secret from the okteto UI. (and deploying it like: "helm upgrade…

---

## [Escaping characters using "docker-compose"](https://community.okteto.com/t/escaping-characters-using-docker-compose/1242)

<div class="topic-metadata">

**Author:** [@andrevtg](https://community.okteto.com/u/andrevtg)\
**Replies:** 3\
**Last updated:** [May 10, 2024, 6:28pm UTC](https://community.okteto.com/t/escaping-characters-using-docker-compose/1242 "2024-05-10T18:28:32Z")

</div>

Hi. I need to use “/$2” string in an ingress annotation under docker-compose, but apparently this can’t be escaped to avoid internal envsubst. I have managed to circunvent this by “brute force” as below. Is there a bet…

---

## [I disabled the Okteto Autoscaler and now my cluster doesn't scale down](https://community.okteto.com/t/i-disabled-the-okteto-autoscaler-and-now-my-cluster-doesnt-scale-down/1267)

<div class="topic-metadata">

**Author:** [@pchico83](https://community.okteto.com/u/pchico83)\
**Replies:** 1\
**Last updated:** [May 9, 2024, 2:51pm UTC](https://community.okteto.com/t/i-disabled-the-okteto-autoscaler-and-now-my-cluster-doesnt-scale-down/1267 "2024-05-09T14:51:03Z")

</div>

I disabled the Okteto Autoscaler: autoscaler: enabled: false and now my clusters doesn’t scale down anymore. How can I fix it?

---

## [Error using dev services with non-root containers](https://community.okteto.com/t/error-using-dev-services-with-non-root-containers/1263)

<div class="topic-metadata">

**Author:** [@dmccorma](https://community.okteto.com/u/dmccorma)\
**Replies:** 3\
**Last updated:** [April 29, 2024, 4:50pm UTC](https://community.okteto.com/t/error-using-dev-services-with-non-root-containers/1263 "2024-04-29T16:50:21Z")

</div>

I have a service (xiam-fpm-server) that is dependent on two additional services (xiam-web-server and xiam-frontend). I have remote development working when configuring each of the three services as separate entries in th…

---

## [Important Update: Changes to Docker Compose Deployment Behavior in Okteto](https://community.okteto.com/t/important-update-changes-to-docker-compose-deployment-behavior-in-okteto/1246)

<div class="topic-metadata">

**Author:** [@nacho](https://community.okteto.com/u/nacho)\
**Replies:** 0\
**Last updated:** [April 15, 2024, 4:06pm UTC](https://community.okteto.com/t/important-update-changes-to-docker-compose-deployment-behavior-in-okteto/1246 "2024-04-15T16:06:04Z")

</div>

Dear Okteto Community, We’re writing to announce an important adjustment to a feature within Okteto that affects the deployment of Docker Compose files onto Kubernetes clusters. Starting with upcoming Okteto CLI 2.26.1…

---

## [Important Update: Migrating from Okteto Stacks to Docker Compose](https://community.okteto.com/t/important-update-migrating-from-okteto-stacks-to-docker-compose/1262)

<div class="topic-metadata">

**Author:** [@pchico83](https://community.okteto.com/u/pchico83)\
**Replies:** 0\
**Last updated:** [April 26, 2024, 11:35am UTC](https://community.okteto.com/t/important-update-migrating-from-okteto-stacks-to-docker-compose/1262 "2024-04-26T11:35:34Z")

</div>

In January 2021, we announced compatibility between Okteto Stacks and Docker Compose. Okteto Stacks is an application format inspired by Docker Compose to simplify application deployment on Kubernetes. Since the Docker C…

---

## [Volume issue when trying to make use of dev services](https://community.okteto.com/t/volume-issue-when-trying-to-make-use-of-dev-services/1260)

<div class="topic-metadata">

**Author:** [@dmccorma](https://community.okteto.com/u/dmccorma)\
**Replies:** 3\
**Last updated:** [April 25, 2024, 7:17pm UTC](https://community.okteto.com/t/volume-issue-when-trying-to-make-use-of-dev-services/1260 "2024-04-25T19:17:39Z")

</div>

Hello. My application is written in PHP, and uses two separate deployments – a www-web deployment, running an nginx container to serve static files, and a www-php deployment, running php-fpm for serving dynamic content. …

[Next page](https://community.okteto.com/c/help/6.md?page=1)
